Skip to main content

Dependency Versions


The version range of ESLint currently supported is ^6.0.0 || ^7.0.0 || ^8.0.0.

We generally support at least the latest two major versions of ESLint.


This project makes an effort to support Active LTS and Maintenance LTS release statuses of Node according to Node's release document. Support for specific Current status releases are considered periodically.


The version range of TypeScript currently supported is >=3.3.1 <5.2.0.

These versions are what we test against.

We will always endeavor to support the latest stable version of TypeScript. Sometimes, but not always, changes in TypeScript will not require breaking changes in this project, and so we are able to support more than one version of TypeScript. In some cases, we may even be able to support additional pre-releases (i.e. betas and release candidates) of TypeScript, but only if doing so does not require us to compromise on support for the latest stable version.

Note that our packages have an open peerDependency requirement in order to allow for experimentation on newer/beta versions of TypeScript.

If you use a non-supported version of TypeScript, the parser will log a warning to the console. If you want to disable this warning, you can configure this in your parserOptions. See: Packages > Parser > warnOnUnsupportedTypeScriptVersion.

Dependant Version Upgrades

See Maintenance > Dependent Version Upgrades for maintenance steps to update these versions.